Velodoc XP Account Creation Error

May 30, 2008 at 7:35 PM
Jacques,

I created Velodoc XP Account following the steps in the Installation Guide. Then tested the Plug In, which was successful.
But when I tried sending  email ,the transfer fails with error:

System.ServiceModel.ProtocolException: The content type text/html; charset=utf-8 of the response message does not match the content type of the binding (multipart/related; type="application/xop+xml"). If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly. The first 1024 bytes of the response were: '<html>
    <head>
        <title>Configuration Error</title>
        <style>
         body {font-family:"Verdana";font-weight:normal;font-size: .7em;color:black;}
         p {font-family:"Verdana";font-weight:normal;color:black;margin-top: -5px}
         b {font-family:"Verdana";font-weight:bold;color:black;margin-top: -5px}
         H1 { font-family:"Verdana";font-weight:normal;font-size:18pt;color:red }
         H2 { font-family:"Verdana";font-weight:normal;font-size:14pt;color:maroon }
         pre {font-family:"Lucida Console";font-size: .9em}
         .marker {font-weight: bold; color: black;text-decoration: none;}
         .version {color: gray;}
         .error {margin-bottom: 10px;}
         .expandable { text-decoration:underline; font-weight:bold; color:navy; cursor:hand; }
        </style>
    </head>

    <body bgcolor="white">

            <span><H1>Server Error in '/' Application.<hr width=100% size=1 color=silver></H1>

            <h2> <i>Configuration Error</i> </h2></sp'. ---> System.Net.WebException: The remote server returned an error: (500) Internal Server Error.
   at System.Net.HttpWebRequest.GetResponse()
   at System.ServiceModel.Channels.HttpChannelFactory.HttpRequestChannel.HttpChannelRequest.WaitForReply(TimeSpan timeout)
   --- End of inner exception stack trace ---

Server stack trace:
   at System.ServiceModel.Channels.HttpChannelUtilities.ValidateRequestReplyResponse(HttpWebRequest request, HttpWebResponse response, HttpChannelFactory factory, WebException responseException)
   at System.ServiceModel.Channels.HttpChannelFactory.HttpRequestChannel.HttpChannelRequest.WaitForReply(TimeSpan timeout)
   at System.ServiceModel.Channels.RequestChannel.Request(Message message, TimeSpan timeout)
   at System.ServiceModel.Dispatcher.RequestChannelBinder.Send(Message message, TimeSpan timeout)
   at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
   at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs)
   at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
   at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:
   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
   at ITransferService.Upload(RemoteFileDescriptor request)
   at TransferServiceClient.ITransferService.Upload(RemoteFileDescriptor request)
   at TransferServiceClient.Upload(String ContentType, String Email, Guid FileGuid, String FileName, String HashCode, Int64 Length, String SecurityCode, Stream Stream)
   at Memba.Transfer.PlugIns.WCFPlugIn.Upload(Object state)




I went back to Test if the PlugIn settings are correct. Same error message poped up when clicked on Test button.

Jun 1, 2008 at 2:57 PM
Edited Jun 2, 2008 at 9:05 AM
Ganesh,

"The remote server returned an error: (500) Internal Server Error."
The error seems to be with Velodoc XP Edition, not with the Outlook Add-In.

I do not have enough information to reproduce the problem.
Which release of Velodoc XP Edition did you install? Release 1.1?
Where did you install it? Which platform?
If you have installed it at http://localhost/VelodocXP, can you navigate the web pages and post files?
Can you display http://localhost/VelodocXP/wcfTransferService.svc?
What account settings did you use?
What is the DebugView trace?
...

Jacques
Jun 2, 2008 at 6:26 PM
Jacques,

This error message was received as the  wcfTransferService.svc was not installed. I re-installed VelodocXP 1.1 and now there is no error message noticed. It is working fine.
Jun 4, 2008 at 8:49 PM
Hi Jacques,

I am noticing again the Error Message "The remote server returned an error: (500) Internal Server Error."

This error is noticed for Velodoc EnterPrise Plug In test.

I was reciving other error message for Velodoc XP PlugIn. I reinstalled Velodoc XP1.1 and the Plug In test is going through fine now.
I can navigate to http://localhost/VelodocXP  but I cannot send files from here. I am sending screenshot for same in RentACoder and debug trace.

I am testing on Win XP.
Account Settings  for Velodoc Ent are as below,

Host : www.velodoc.net
UserName : test123
Password: tBES*d44
email: kiran.nive@gmail.com
Jun 5, 2008 at 9:00 AM
Ganesh,

I am confused with your last post. Velodoc Enterprise and Velodoc XP Edition are two separate products and two separate plug-ins. In these circumstances, can you please keep two separate discussion threads? You already have a discussion thread about Velodoc Enterprise Edition Accounts at http://www.codeplex.com/velodocaddin/Thread/View.aspx?ThreadId=28715.

As I have already told you in this discussion thread, you cannot test Velodoc Enterprise for now. There is a warning in the description of the Outlook Add-In Release 1.0 and also a discussion thread about this at http://www.codeplex.com/velodocaddin/Thread/View.aspx?ThreadId=27984. We have not yet deployed the required upgrades on www.velodoc.net so do not test Velodoc Enterprise Edition now, it is not expected to work yet.

As far as Velodoc XP Edition is concerned, you apparently get a 404 File not found error in the .LOG file which means that the service cannot be found. Note that the .LOG file does not seem to correspond to the screenshot, since the message that you get in the screenshot should normally also be logged.
Can you launch http://192.168.0.100/velodocxp/ in a web browser?
Can you also launch http://192.168.0.100/velodocxp/wcfTransferService.svc?
If you also get errors in the browser, you can get more details about the error by changing the customErrors element as explained in http://msdn.microsoft.com/en-us/library/h0hfz6fc.aspx.

Regards,
Jacques