New Account in Account Settings not reflected in Package Editor.

Jun 10, 2008 at 3:18 PM
Jacques,

This is for the limited Account user.( Could not check as Admin as it is having some issue).

Suppose there are 2 accounts (UNC and BITS)already created in Account Settings, now add the 3rd account.

Create an Account in the Account settings say FTP Server Account, save the settings and open Package Editor.
In the Status bar there will be only 2 accounts (UNC and BITS) showing up. The newly created FTP Account does not come up in the list.
To see the FTP Account in Package Editor you need to close the New Message window and re open it.

This issue is not noticed for the first account created in the Account settings. It pops up in the Package editor.
Coordinator
Jun 10, 2008 at 5:36 PM
Edited Jun 10, 2008 at 5:37 PM
Ganesh,

Well spotted (it will be the same with any user) but we will not fix that for v1.0, since it is complicated to deal with properly and the workaround is easy. Also you are not creating a new account every day, do you?

I know another variant of the same problem:
- open the package editor.
- open the account settings from the file menu of the transfer controller and create a new account.
- the package editor is not updated with the new account.

The issue is the package editor runs in the Outlook process and the transfer controller runs in its own process.
You either have to use .NET remoting callbacks (complex) or an easier solution is to use registry change events since accounts are stored in the registry.

This is a v2.0 enhancement.
Jun 11, 2008 at 6:12 PM
Workaround sounds good.