Error Message when setting an Account.

Oct 20, 2008 at 10:47 PM
I installed the VelodocXP edtion on a server, and I create a VelodocXP account based on this web server by the Account Setting Dialog. I entered correct Host, Path, Email and Security Code. But it always show the error message. It works if the server is my local machine. Any ideas and solutions will be appreciated.

The error message: The remote server returned an unexpected response:(413) RequestEntityTooLarge.

Coordinator
Oct 21, 2008 at 7:55 AM
What size of files do you plan to transfer?

By default, Velodoc XP Edition is configured to limit the size of POSTs to 100 MB.
The documentation of Velodoc XP Edition (Documentation folder in the Windows start menu) explains how to configure this.

If you are using IIS 6, you need to configure the httpRuntime section in web.config. See http://msdn.microsoft.com/en-us/library/e1f13641(VS.71).aspx.
If you are using IIS 7, you need to configure the requestLimits section in web.config. See http://msdn.microsoft.com/en-us/library/ms689462.aspx.

Note that there are other ways to limit the size of POSTs, for example using Microsoft URLScan or 3rd party software.
Oct 21, 2008 at 2:25 PM
Thanks very much for your response. I will try according to your solution.


From: jlchereau [mailto:notifications@codeplex.com]
Sent: Tuesday, October 21, 2008 1:56 AM
To: Jeffrey Wang
Subject: Re: Error Message when setting an Account. [velodocaddin:38103]

From: jlchereau

What size of files do you plan to transfer?

By default, Velodoc XP Edition is configured to limit the size of POSTs to 100 MB.
The documentation of Velodoc XP Edition (Documentation folder in the Windows start menu) explains how to configure this.

If you are using IIS 6, you need to configure the httpRuntime section in web.config. See http://msdn.microsoft.com/en-us/library/e1f13641(VS.71).aspx.
If you are using IIS 7, you need to configure the requestLimits section in web.config. See http://msdn.microsoft.com/en-us/library/ms689462.aspx.

Note that there are other ways to limit the size of POSTs, for example using Microsoft URLScan or 3rd party software.
Oct 21, 2008 at 2:56 PM
Hi Mr jlchereau,
I didn't set anything regarding the size of the files. Just want to set an VelodocXP Account. I entered the values then click the test button, the error shows up.


From: jlchereau [mailto:notifications@codeplex.com]
Sent: Tuesday, October 21, 2008 1:56 AM
To: Jeffrey Wang
Subject: Re: Error Message when setting an Account. [velodocaddin:38103]

From: jlchereau

What size of files do you plan to transfer?

By default, Velodoc XP Edition is configured to limit the size of POSTs to 100 MB.
The documentation of Velodoc XP Edition (Documentation folder in the Windows start menu) explains how to configure this.

If you are using IIS 6, you need to configure the httpRuntime section in web.config. See http://msdn.microsoft.com/en-us/library/e1f13641(VS.71).aspx.
If you are using IIS 7, you need to configure the requestLimits section in web.config. See http://msdn.microsoft.com/en-us/library/ms689462.aspx.

Note that there are other ways to limit the size of POSTs, for example using Microsoft URLScan or 3rd party software.
Coordinator
Oct 21, 2008 at 3:36 PM
Edited Oct 21, 2008 at 4:03 PM
If I understand correctly, you:
  1. Setup your account in Memba Velodoc Outlook Add-In, designating a Velodoc XP server
  2. Click the Test button
  3. Get the Http 413 error (request entity is too large)

I have done the same this morning and got no error so I assume this is really a configuration issue.

Oct 21, 2008 at 3:40 PM
The steps you described is exactly what I am doing. I try the web service and let you know. Thanks.


From: jlchereau [mailto:notifications@codeplex.com]
Sent: Tuesday, October 21, 2008 9:37 AM
To: Jeffrey Wang
Subject: Re: Error Message when setting an Account. [velodocaddin:38103]

From: jlchereau

If I understand correctly, you:
  1. Setup your account in Memba Velodoc Outlook Add-In, designating a Velodoc XP server
  2. Click the Test button
  3. Get the Http 413 error (request entity is too large)

I have done the same this morning and got no error so I assume this is really a configuration issue.

Can you upload files to Velodoc XP Edition using the web interface (i.e. the browser not the Outlook Add-In)?
Can you access http:///VelodocXP/wcfTransferService.svc?wsdl?You can use WcfTestClient.exe (or alternatively <a

Oct 21, 2008 at 3:47 PM

The Velodoc XP server you are using is local machine or remote server?



From: jlchereau [mailto:notifications@codeplex.com]
Sent: Tuesday, October 21, 2008 9:37 AM
To: Jeffrey Wang
Subject: Re: Error Message when setting an Account. [velodocaddin:38103]

From: jlchereau

If I understand correctly, you:
  1. Setup your account in Memba Velodoc Outlook Add-In, designating a Velodoc XP server
  2. Click the Test button
  3. Get the Http 413 error (request entity is too large)

I have done the same this morning and got no error so I assume this is really a configuration issue.

Can you upload files to Velodoc XP Edition using the web interface (i.e. the browser not the Outlook Add-In)?
Can you access http:///VelodocXP/wcfTransferService.svc?wsdl?You can use WcfTestClient.exe (or alternatively <a

Coordinator
Oct 21, 2008 at 3:59 PM
Remote server: I have understood from your report that you only experience the issue with the remote server configuration.
Oct 21, 2008 at 4:05 PM
I need to find out another clean test server to install Velohoc XP first, then configure the Add-In at client side. thanks very much. I will keep the updates to you.


From: jlchereau [mailto:notifications@codeplex.com]
Sent: Tuesday, October 21, 2008 9:59 AM
To: Jeffrey Wang
Subject: Re: Error Message when setting an Account. [velodocaddin:38103]

From: jlchereau

Remote server: I have understood from your report that you only experience the issue with the remote server configuration.
Oct 27, 2008 at 5:05 PM
Hello Sir,
Do you remember last time we discussed the issue regarding the Account Setting against a remote server. Now there is another issue come out, I installed the Velodoc XP Edition on a Remote Server, then installed the Add_In on my local machine. I create an account and click the test button, it always show the error message as follow:

From: jlchereau [mailto:notifications@codeplex.com]
Sent: Tuesday, October 21, 2008 1:56 AM
To: Jeffrey Wang
Subject: Re: Error Message when setting an Account. [velodocaddin:38103]

From: jlchereau

What size of files do you plan to transfer?

By default, Velodoc XP Edition is configured to limit the size of POSTs to 100 MB.
The documentation of Velodoc XP Edition (Documentation folder in the Windows start menu) explains how to configure this.

If you are using IIS 6, you need to configure the httpRuntime section in web.config. See http://msdn.microsoft.com/en-us/library/e1f13641(VS.71).aspx.
If you are using IIS 7, you need to configure the requestLimits section in web.config. See http://msdn.microsoft.com/en-us/library/ms689462.aspx.

Note that there are other ways to limit the size of POSTs, for example using Microsoft URLScan or 3rd party software.
Coordinator
Oct 27, 2008 at 5:33 PM
Jeffrey,

Can you re-edit your message because the picture is not available.
Can you please also avoid copying the previous message which clutters the discussion.
Thx.
Oct 27, 2008 at 5:38 PM
The error message:
The requested service wcfTransferService.svc could not be activated, See the server's diagnostic trace logs for more information.


From: jlchereau [mailto:notifications@codeplex.com]
Sent: Monday, October 27, 2008 11:34 AM
To: Jeffrey Wang
Subject: Re: Error Message when setting an Account. [velodocaddin:38103]

From: jlchereau

Jeffrey,

Can you re-edit your message because the picture is not available.
Can you please also avoid copying the previous message which clutters the discussion.
Thx.
Coordinator
Oct 27, 2008 at 7:19 PM
Edited Oct 30, 2008 at 9:29 AM
I am going to need more information here.
Can you access http://[host]/VelodocXP/wcfTransferService.svc?WSDL where [host] is the fully qualified domain name or IP address of the server hosting Velodoc XP?
Have you enabled the diagnostic trace logs? Can you send them?